Computer Repair and PC Support across the UK

As Featured in the Guardian

Free Computer Support Forum

Software Related Issues

Topic:

HUAWEI - E122 modem isn't workin on my windows XP machine.

Posted by: Reena S.      2 Jun 2010 @ 01:57
HUAWEI - E122 modem isn't workin on my windows XP machine.

Hello There,

I am getting a very strange issue. Please help me if you can.

I bought this wireless modem just 2 days ago. I plugged that in and it was auto detected ..
1. I got 2 drives in My Computer.
2. I got USB Mass Storage in Device Manager.
3. It wasn't auto-play set .. so I set it for autoplay using gpedit.msc ... and restarting the computer.
4. After restarting, the modem installation started automatically.
5. I installed the software,
6. In device manager, Under Modems, the 3 Modem appears.
7. In device manager, Under ports section, the 2 new ports created by the installation appears (COM 7 and COM something ... )
8. I start the 3 utility from desktop, could see the signals, clicked connect and i was online ... No issues .. everything worked like a charm ...

The problem is ::::
As soon as a) I close the lid of my laptop (stand by) OR b) unplug and replug the modem OR c) restart my laptop, I can never get the USB working.
Symptoms are:
1. The 2 drives in My Computer dis-appears.
2. USB Mass Storage in Device Manager dis-appears.
3. Under Modems, the 3 Modem dis-appears.
4. Under ports section, the 2 new ports created by the installation dis-appears.
5. No matter how many times, I unplug and replug the modem, it's not detected by the computer.

I tried the same USB modem on 2 other laptops, on both of them it worked fine ... No issues.
I got this new modem replaced, the new modem doing the same thing.
Prior to this one (E122), I have used 2 modems (different models) and never got any problems.

The only solution to get it working is, to unplug the modem, un-install the software, restart the computer and plug back in and re-install it again. However, I can't do that thousand times in a day.

Any suggestions please .. what's wrong and how can I fix it ?

Reply by: Alan B. PCIQ IT ProfessionalIT Professional in Cambridge, CB22      2 Jun 2010 @ 07:46
RE: HUAWEI - E122 modem isn't workin on my windows XP machine.

So you have established that your problem is not the modem, which works on other computers, but the way your USB ports behave. When you put your laptop to sleep by closing the lid perhaps they don't wake up again? And when you restart your computer are you really restarting it or getting it to sleep/hibernate? What make and model of laptop is it?

3 of 3 people found the above post helpful
Was this post helpful?  I thought this post was helpful  I thought this post was not helpful
Report this post
Reply by: Jon S. PCIQ IT ProfessionalIT Professional in Morecambe, LA3      2 Jun 2010 @ 08:03
RE: HUAWEI - E122 modem isn't workin on my windows XP machine.

theres a known problem with some laptop chipsets where the USB ports won't power back up after the computer has gone into sleep or standby.
fox for that is to disable powersaving features on the USB root hubs in device maanager
However that does not account for the problem you get after shutting the machine down - unless as Alan says, you are not actually shutting it down

0 of 0 people found the above post helpful
Was this post helpful?  I thought this post was helpful  I thought this post was not helpful
Report this post
Reply by:  .      2 Jun 2010 @ 09:43
RE: HUAWEI - E122 modem isn't workin on my windows XP machine.

Thanks for suggestions :)

In device manager > USB Root Hub > properties > Power Management. I have already un-ticked "Allow the computer to turn off this device to save power" ...

And I go to start > shut down > restart .. to restart my computer ... That doesn't matter as I have also tried to restart by holding the power button for a few seconds, that is, complete restart. And as I said earlier, when everything is working fine, I just disconnect and then simply unplug and replug the modem makes the modem un-detectable... windows "Found New hardware" wizard just stuck at the some point, doesn't even show me "USB Mass Storage" message.I can't think of the cause for this.

This is lenovo Thinkpad T400 ... This USB modem did work fine on another same model laptop.

I was on phone with three support whole day, the other day and after a lot of troubleshooting they also mentioned something about updating the laptop chipset drivers .....?? Is that the reason .. ??

Also, today I upgraded the firmware of this modem from three weksite, just thought may be that will fix this issue (http://www.three.com.au/cs/ContentServer?c=Page&pagename=Three%2FPage%2FBusinessVideoCallingTemplate&cid=1215747787891)

Any other idea's please ... ?? I have tried many things. Now i am truly curious to fix this. What's wrong here .. ??

1 of 1 people found the above post helpful
Was this post helpful?  I thought this post was helpful  I thought this post was not helpful
Report this post
Reply by: Jon S. PCIQ IT ProfessionalIT Professional in Morecambe, LA3      2 Jun 2010 @ 10:01
RE: HUAWEI - E122 modem isn't workin on my windows XP machine.

they may have a point about the drivers

could be worth updating both the chipset and USB chipset drivers, depending on the chipsets used

Do you know what the chipset on the machine is? I don't have time to check myself now

0 of 0 people found the above post helpful
Was this post helpful?  I thought this post was helpful  I thought this post was not helpful
Report this post
Reply by:  .      2 Jun 2010 @ 10:37
RE: HUAWEI - E122 modem isn't workin on my windows XP machine.

No idea about the chipset thingi ... but will google to find out ... :) .. However, I will still wait for some other ideas because I don't have the chipset drivers anymore ... so let's see ....

1 of 1 people found the above post helpful
Was this post helpful?  I thought this post was helpful  I thought this post was not helpful
Report this post
Reply by: Alan B. PCIQ IT ProfessionalIT Professional in Cambridge, CB22      2 Jun 2010 @ 12:44
RE: HUAWEI - E122 modem isn't workin on my windows XP machine.

You had to fiddle with your Group Policy settings to get auto-play to run (although I don't think this was necessary - you could have just run the setup program manually). And the first time you did this the Huawei modem WAS detected when you restarted your computer. So if you DON'T install the modem software, can you still detect the modem after a restart?

Do you have any other restrictive policy settings set?

1 of 1 people found the above post helpful
Was this post helpful?  I thought this post was helpful  I thought this post was not helpful
Report this post
Reply by:  .      2 Jun 2010 @ 23:15
RE: HUAWEI - E122 modem isn't workin on my windows XP machine.

Yes Alan,

This modem always gets detected by the laptop as long as I don't install the modem software. I can unplug and replug (using safely remove the device process)it any number of times and the 2 drives always appear in my computer (without even restarting the computer).. It's just when I install it, then it mess up the things... as if these modem drivers are corrupting my system... ...

Yes I agree that I didn't need to make autoplay working. Autoplay does nothing but call the setup.exe anyway .. which I could have run manually.... but I did it just to try everything people suggested.

Any other group policy settings ... like what ?? Is there any easy way to find out what policies are set in my computer instead of opening up each and every policy .. ??

0 of 0 people found the above post helpful
Was this post helpful?  I thought this post was helpful  I thought this post was not helpful
Report this post
Reply by:  .      2 Jun 2010 @ 23:19
RE: HUAWEI - E122 modem isn't workin on my windows XP machine.

I have quickly tried a few policies and mostly these are Not Configured ... Earlier, "Turn Off Autoplay" was also set as "Not Configured" but I changed that to disabled.

Please suggest any specific policy to check ???

4 of 4 people found the above post helpful
Was this post helpful?  I thought this post was helpful  I thought this post was not helpful
Report this post
Reply by:  .      2 Jun 2010 @ 23:28
RE: HUAWEI - E122 modem isn't workin on my windows XP machine.

Yes I checked almost all policies .. All are "Not Configured"

0 of 0 people found the above post helpful
Was this post helpful?  I thought this post was helpful  I thought this post was not helpful
Report this post
Reply by: Alan B. PCIQ IT ProfessionalIT Professional in Cambridge, CB22      3 Jun 2010 @ 09:01
RE: HUAWEI - E122 modem isn't workin on my windows XP machine.

Group Policies was just a shot in the dark but it seems fairly clear that your problem is that there is something unusual about your particular computer that comes into conflict with the Huawei software after you reboot. It could be hardware or software or configuration.

This is another shot in the dark but suppose you install the modem then use DeviCe Manager to change the COM ports it uses to something higher. I have read about problems with clashing COM ports, although not really the problem you are experiencing.

0 of 0 people found the above post helpful
Was this post helpful?  I thought this post was helpful  I thought this post was not helpful
Report this post
Reply by:  .      3 Jun 2010 @ 10:48
RE: HUAWEI - E122 modem isn't workin on my windows XP machine.

Alan,

When I plugged the modem, in Device manager, under ports, I get yellow question mark (with port = COM7), I changed that to COM16 ... update the drivers and the USB modem was then detected, ran the installation successfully. and the in device manager I got,

Under PORTS
HUAWEI Mobile Commect - 3G Application Interface (COM7) ... remember that I changed the COM7 to COM 16 .. but the install changed it back to COM7.

AND
HUAWEI Mobile Commect - 3G PC UI Interface (COM9)

Under MODEM
HUAWEI Mobile Connect - 3G Modem (COM6)


Also, I have updated the BIOS drivers + Chip set drivers on this laptop today .... ???

:(

0 of 0 people found the above post helpful
Was this post helpful?  I thought this post was helpful  I thought this post was not helpful
Report this post
Reply by:  .      3 Jun 2010 @ 11:01
RE: HUAWEI - E122 modem isn't workin on my windows XP machine.

RESOLUTION --- :)

There were 2 vmware network adaptors in device manager > Network adaptors section > (I had vmware installed on my laptopn). I un-installed vmware player, restarted my computer ... and it's all working as normal, for the first time ..... I tested it many a times by unplugging and replugging the modem ... it's working ... it's working ... Yaay ... :) ....

Thanks for your suggestion L :)

24 of 25 people found the above post helpful
Was this post helpful?  I thought this post was helpful  I thought this post was not helpful
Report this post
Reply by: Alan B. PCIQ IT ProfessionalIT Professional in Cambridge, CB22      3 Jun 2010 @ 11:04
RE: HUAWEI - E122 modem isn't workin on my windows XP machine.

So it is actually using COM ports 6, 7 & 9? You can use the tool here to list your COM port usage http://support.microsoft.com/kb/819036 . That way you could see if anything else is competing for the same COM ports.

1 of 1 people found the above post helpful
Was this post helpful?  I thought this post was helpful  I thought this post was not helpful
Report this post
Reply by: Jon S. PCIQ IT ProfessionalIT Professional in Morecambe, LA3      3 Jun 2010 @ 11:04
RE: HUAWEI - E122 modem isn't workin on my windows XP machine.

download and run USBDEVIEW from http://www.nirsoft.net/utils/usb_devices_view.html

Unplug ALL USB devices and then use it to remove all entries for all USB items (including hubs and controllers) from the registry
Reboot and let the USB controllers redetect
Reboot again, plug the dongle in (nothing else) and see if its found properly
If it is, then plug in the other USB devices one by one

0 of 8 people found the above post helpful
Was this post helpful?  I thought this post was helpful  I thought this post was not helpful
Report this post
Reply by: Laurent C.      2 Sep 2010 @ 16:55
RE: HUAWEI - E122 modem isn't workin on my windows XP machine.

Thanks 10 thousands of times !! I had been in difficulties with this problem for one month and spent hours reading tens of articles, with no other left idea than reinstalling windows xp !! I saw your solution yesterday, uninstalled VM Player and ... it worked back again too !! Thanks again !

4 of 4 people found the above post helpful
Was this post helpful?  I thought this post was helpful  I thought this post was not helpful
Report this post
Reply by: 00 0.      17 Nov 2010 @ 02:52
RE: HUAWEI - E122 modem isn't workin on my windows XP machine.

these modems are realy shit, i have big problems with this one, i must reinstall the software every week, it just shows no service or connects very badly after time of using. i know that has nothing to do with pwr managment or that peaco of shit installed 200com ports on my system, can you imagine that? that beta MS program shows me that my lap doesn't have com ports at all :DDDD this is realy pissing me off. 3connect software it's jus tragedy, it runs browser under it's process and if it disconects, when reconected the browser gets offlline mode and you must restart vasting your bandwidth, i tried times more things than listed here, and i dont think there ever will be a sollution. there is autoupdate process for soft but it never gets updated, maybe they think it's all perfect working...

0 of 0 people found the above post helpful
Was this post helpful?  I thought this post was helpful  I thought this post was not helpful
Report this post
Reply by: 00 0.      17 Nov 2010 @ 02:52
RE: HUAWEI - E122 modem isn't workin on my windows XP machine.

these modems are realy shit, i have big problems with this one, i must reinstall the software every week, it just shows no service or connects very badly after time of using. i know that has nothing to do with pwr managment or that peaco of shit installed 200com ports on my system, can you imagine that? that beta MS program shows me that my lap doesn't have com ports at all :DDDD this is realy pissing me off. 3connect software it's jus tragedy, it runs browser under it's process and if it disconects, when reconected the browser gets offlline mode and you must restart vasting your bandwidth, i tried times more things than listed here, and i dont think there ever will be a sollution. there is autoupdate process for soft but it never gets updated, maybe they think it's all perfect working...

0 of 1 people found the above post helpful
Was this post helpful?  I thought this post was helpful  I thought this post was not helpful
Report this post
Reply by: mark C.      13 Dec 2011 @ 15:17
RE: HUAWEI - E122 modem isn't workin on my windows XP machine.

HUAWEI - E122 modem isn't workin on my windows 7 system

0 of 0 people found the above post helpful
Was this post helpful?  I thought this post was helpful  I thought this post was not helpful
Report this post
Reply by: Jon S. PCIQ IT ProfessionalIT Professional in Morecambe, LA3      13 Dec 2011 @ 15:22
RE: HUAWEI - E122 modem isn't workin on my windows XP machine.

read the thread and try some of the suggestions

1 of 1 people found the above post helpful
Was this post helpful?  I thought this post was helpful  I thought this post was not helpful
Report this post
Reply by: ravineel s.      18 Jul 2014 @ 11:26
RE: HUAWEI - E122 modem isn't workin on my windows XP machine.

i had bought the usb moderm huWEI EC122. I USED IT IN WINDOWS 7 FOR A WEEK AND THEN I SWICTHED TO WINDOWS 8..HOWEVER, WHEN I TRIED INSTALLING THE MODERM IT COULDNT INSTALL. T TRIED USING BACK IN WIN7 BUT IT COULDN'T.I TOOK IT TO THE SELLER AND HE SAID THAT THE MODERN IS DESIGNED FOR ONLY WINDOWS 7

IS THERE ANY WAY OF REPAIRING THE MODERM AGAIN AND MAKE IT WORK IN WIN 7.
THANKS

0 of 0 people found the above post helpful
Was this post helpful?  I thought this post was helpful  I thought this post was not helpful
Report this post
Reply by: ravineel s.      18 Jul 2014 @ 11:26
RE: HUAWEI - E122 modem isn't workin on my windows XP machine.

i had bought the usb moderm huWEI EC122. I USED IT IN WINDOWS 7 FOR A WEEK AND THEN I SWICTHED TO WINDOWS 8..HOWEVER, WHEN I TRIED INSTALLING THE MODERM IT COULDNT INSTALL. T TRIED USING BACK IN WIN7 BUT IT COULDN'T.I TOOK IT TO THE SELLER AND HE SAID THAT THE MODERN IS DESIGNED FOR ONLY WINDOWS 7

IS THERE ANY WAY OF REPAIRING THE MODERM AGAIN AND MAKE IT WORK IN WIN 7.
THANKS

0 of 0 people found the above post helpful
Was this post helpful?  I thought this post was helpful  I thought this post was not helpful
Report this post
Reply by: Jon S. PCIQ IT ProfessionalIT Professional in Morecambe, LA3      5 Aug 2014 @ 19:03
RE: HUAWEI - E122 modem isn't workin on my windows XP machine.

as we don't know whats happened to the modem we can't answer that. My guess is you've wiped or corrupted the memory chip which holds the software and drivers
or maybe in reverting to windows 7 you've not installed all the required driver for the PC.
Other than that its very hard for us to comment as you offer no useful information about the problem

0 of 0 people found the above post helpful
Was this post helpful?  I thought this post was helpful  I thought this post was not helpful
Report this post

Do you need computer support?